You may have to sign up for a free Apple Developer Account in order to download Xcode 10 from the developer link that BDAqua provided — unless Apple has relaxed its access privileges for these tools.

How To Download Xcode On Old Mac

If by app, you mean an iOS app for the App Store - the minimum Xcode required for submittal to the store today is 5.1.1, so that computer won't work for you. Honestly, that computer is much too old and restrictive for your needs, I think. I would keep looking. In the case of Catalina that includes all the old-style Mac Pro models, pre-'trash can'. If it's Big Sur you want to run and your Mac is older than 2013/2014 the new macOS just isn't for you, as. I want to install xcode on vmware image mac os x lion 10.7. I went to app store but it won't let me download because it's the latest version which not compatible with lion 10.7. I don't have an developer account. So, is there any way to install an old xcode?


Mac

‎Xcode On The Mac App Store

Alternatively, If all you want is a a compilation environment for Objective-C, C++, and Swift v4.n, the Command Line Tools (macOS 10.13) for Xcode will provide that at 7GB less storage. You would then need a competent programmer's editor, and you can still build hand-coded cocoa applications. This is my preference.